ΓΕΛ ΠΛΗΡΟΦΟΡΙΚΗ (ΑΕΠΠ) Απαντήσεις Θεμάτων Πανελλαδικών 2022

ΘΕΜΑ Α     
Α1.

1-Λ   2-Σ   3-Λ   4-Λ   5-Σ

A2.

α) Δυαδικό δένδρο (binary tree) είναι ένα διατεταγμένο δένδρο, στο οποίο κάθε κόμβος έχει το πολύ δύο παιδιά, το αριστερό και το δεξί παιδί. Κατά συνέπεια κάθε κόμβος μπορεί να έχει αριστερό και δεξιό υποδένδρο.

β)

Α3.

α)

Οι ιδιότητες καθορίζουν τα χαρακτηριστικά (δεδομένα) ενός αντικειμένου. Οι μέθοδοι καθορίζουν τις ενέργειες που κάνει και κατά συνέπεια την συμπεριφορά του αντικειμένου.

β)

  1. Ιδιότητα
  2. Ιδιότητα
  3. Υποκλάση
  4. Ιδιότητα
  5. Ιδιότητα
  6. Μέθοδος
  7. Υποκλάση
  8. Υπερκλάση

Α4.

Γρ.7: Λογικό (Αρχικοποιεί το γινόμενο με 0. Πρέπει ΓΙΝ ← 1)

Γρ.8: Συντακτικό (έχει εισαγωγικά στο 0. Η τιμή είναι αριθμητική)

Γρ.9: Συντακτικό (Το Χ δεν έχει δηλωθεί στις μεταβλητές)

Γρ.15: Συντακτικό (θέλει ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ)

Γρ.16: Λάθος εκτέλεσης (πιθανή διαίρεση με το 0)

ΘΕΜΑ Β     

Β1.

  1. 0
  2. k + 1
  3. k
  4. i
  5. k

Β2.

 

α)

β) 

s ← 0
Διάβασε x
Όσο x > 0 επανάλαβε
   s ← s + x
   Διάβασε x
Τέλος_επανάληψης

ΘΕΜΑ Γ     

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ2022Γ
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: ΔΕΞ, ΠΛ, ΠΡΟ, απ1, απ2
 ΠΡΑΓΜΑΤΙΚΕΣ: τ1, τ2, ΣΕ , ΠΟΣ
 ΛΟΓΙΚΕΣ: ΥΠ

ΑΡΧΗ
 ΔΕΞ ← 0
 ΠΛ ← 0
 ΣΕ ← 0

 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
  ΔΙΑΒΑΣΕ απ1
 ΜΕΧΡΙΣ_ΟΤΟΥ απ1>0
 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

  ΔΙΑΒΑΣΕ απ2
 ΜΕΧΡΙΣ_ΟΤΟΥ απ2>0
 ΔΙΑΒΑΣΕ τ1, τ2
 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ ‘Κατηγορία προιόντος 1 ή 2 :’
  ΔΙΑΒΑΣΕ ΠΡΟ
  ΠΛ ← ΠΛ + 1
  ΥΠ ← ΥΠΑΡΧΕΙ(ΠΡΟ, απ1, απ2)
  ΑΝ ΥΠ = ΑΛΗΘΗΣ ΤΟΤΕ
   ΑΝ ΠΡΟ = 1 ΤΟΤΕ
    απ1 ← απ1 – 1
    ΣΕ ← ΣΕ + τ1
   ΑΛΛΙΩΣ_ΑΝ ΠΡΟ = 2 ΤΟΤΕ

    απ2 ← απ2 – 1
    ΣΕ ← ΣΕ + τ2
   ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ

   ΓΡΑΨΕ ‘Δεν μπορείτε να εξυπηρετηθείτε’
   ΔΕΞ ← ΔΕΞ + 1
  ΤΕΛΟΣ_ΑΝ
  ΠΟΣ ← ΔΕΞ/ΠΛ*100

 ΜΕΧΡΙΣ_ΟΤΟΥ (ΠΟΣ > 20) Ή (απ1=0 ΚΑΙ απ2=0)
 ΓΡΑΨΕ ‘συνολικά έσοδα’,ΣΕ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

! ερώτημα Γ5
ΣΥΝΑΡΤΗΣΗ ΥΠΑΡΧΕΙ(ΠΡΟ, απ1, απ2): ΛΟΓΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: ΠΡΟ, απ1, απ2
ΑΡΧΗ
 ΥΠΑΡΧΕΙ ← ΨΕΥΔΗΣ
 ΑΝ ΠΡΟ=1 ΚΑΙ απ1>0 ΤΟΤΕ
  ΥΠΑΡΧΕΙ ← ΑΛΗΘΗΣ
 ΑΛΛΙΩΣ_ΑΝ ΠΡΟ=2 ΚΑΙ απ2>0 ΤΟΤΕ
  ΥΠΑΡΧΕΙ ← ΑΛΗΘΗΣ

 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΘΕΜΑ Δ     

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ2022Δ
! — Ερωτήματα Δ1 ———–
ΜΕΤΑΒΛΗΤΕΣ

 ΑΚΕΡΑΙΕΣ: i, j, Β[6,6], ΑΘΡ, ΜΕΓ
 ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟΒ[6], temp
 ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[6], ΟΝΜΕΓ, temp1

ΑΡΧΗ
 ! — Ερωτήματα Δ2 ———–
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6

  ΔΙΑΒΑΣΕ ΟΝ[i]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6

  ΔΙΑΒΑΣΕ B[i,i]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6

  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
   ΑΝ i <> j ΤΟΤΕ
    ΔΙΑΒΑΣΕ B[i,j]
   ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ! — Ερωτήματα Δ3 ———–
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ
  ΑΘΡ ← 0

  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
   ΑΘΡ ← ΑΘΡ + B[i,j]

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΟΒ[i] ← ΑΘΡ/6
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ! — Ερωτήματα Δ4 ———–
 ΜΕΓ -50

 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
  ΑΝ B[i,i] > ΜΕΓ ΤΟΤΕ
   ΜΕΓ B[i,i]
   ΟΝΜΕΓ ΟΝ[i]
  ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΡΑΨΕ ‘Όνομα σχολείου με την μεγαλίτερη βαθμολογία από Κρ.Επ’, ΟΝΜΕΓ
 ! — Ερωτήματα Δ5 ———–
 ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 6
  ΓΙΑ j ΑΠΟ 6 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
   ΑΝ (MOΒ[j] > MOΒ[j-1]) Ή (MΟΒ[j] = MOΒ[j-1] ΚΑΙ ON[j < ON[j-1]) ΤΟΤΕ
    temp ← MOΒ[j]
    ΜΟΒ[j] ← ΜΟΒ[j-1]

    MOΒ[j-1] ← temp
    temp1 ← ON[j]

    ΟΝ[j] ON[j-1]
    ON[j-1] ← temp1
   ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
  ΓΡΑΨΕ ON[i],MOΒ[i]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 


Μπάμπης Μπουλής
Καθηγητής Πληροφορικής ΠΕ19

Master of Science in Computer Engineering

Σχολιάστε

Αυτός ο ιστότοπος χρησιμοποιεί το Akismet για να μειώσει τα ανεπιθύμητα σχόλια. Μάθετε πώς υφίστανται επεξεργασία τα δεδομένα των σχολίων σας.

error: το περιεχόμενο προστατεύεται !!